Squarebox

Basic operation

Views

CatDV's main application window displays a list of clips. These can be displayed in one of three main ways:

  • List view - a spreadsheet-like table, one row per clip, with a choice of which columns are displayed.
  • Film strip view - where each movie clip is shown on one line as a sequence of thumbnails.
  • Grid view - a two-dimensional grid of clips, each shown with its poster thumbnail.

Click on the List, Film Strip or Grid toolbar buttons to select the next view of that type. You can have different views of each basic type (eg. with different columns shown, or different thumbnail sizes), and select a particular named view from the drop down list - see Customising views for more details.

Main window

When using the main window you can:

  • Apply filtering or grouping to limit the display to particular clips of interest.
  • Have more than one window open on the same catalog with the New view command. Changes you make in one window will be reflected in the other but you can change the layout of each as required.
  • Select one or more clips with the mouse then right click (control-click on the Macintosh) to display a popup menu of operations applicable to the selected clip(s).
  • Display details of the selected clip and play media for the clip either in the details panel at the top of the main window or in a separate window
  • You can open the media file by launching it in its default application.
  • Press Reset View to restore the window to its default state and show all the clips in the current catalog, with no filtering or grouping applied and the tree navigator and details panel showing.

To display a given clip in a separate window use the appropriate toolbar button or menu command, or double click on the clip. (You can configure the double click action in Preferences, or hold down the control key while you double click for an alternate action.)

See also: Tree navigator, Quick start guide, Summary mode

List views

In a list view you can change the order or width of the columns by dragging the column headers. Press Cmd/Ctrl-\ (or use the Adjust column widths command) to automatically set the column widths. These changes are temporary unless you save the view definition.

You can edit values directly in a list view by checking the Allow cell editing option in Preferences.

Sorting clips

Clips have both a 'natural' order within the catalog (usually the order they were imported in) and a 'display' order within the current window.

  • Click on a column header (when in a list view) or use the Order By menu to change the order that clips are displayed in.
  • Use Random shuffle to randomize the display order (eg. for a slide show).
  • Use Reverse to reverse the display order of clips.
  • Use Make clip order permanent to rearrange clips in the catalog according to their current display order.
  • Drag and drop selected clips within the window to manually rearrange their order in the catalog.

Clip details panel

Use the clip details panel at the tope of the main window to view a selected clip. This includes playing the movie, viewing all the properties of the clip, and entering your own log notes.

You can show or hide the clip details panel by toggling the clip details toolbar button or using the View menu. You can also choose whether to split the panel and move the fields list to the right of the window by selecting Detached Details.

In earlier versions of CatDV the functionality of the details panel was provided in a separate window by the old details dialog. This is still available, if you enable the old-style details dialog in Preferences, though in most cases the new clip details panel has greatly improved functionality.

Viewing media

There are three panels that show the different media representations available for a clip: thumbnail images, the original movie, or a low-resolution proxy movie.

  • Under the Thumbnails tab you can select a different poster for the clip from among the available thumbnails or delete unwanted thumbnails.
  • Under the Movie tab you can play the media for the movie (if it's available online), mark In and Out points (or jump to previously set In and Out points), and create a new poster thumbnail from the current frame.
  • The Proxy tab is similar to the Movie tab but plays the proxy movie (previously referred to as a "preview" movie) rather than original media.
  • If the clip represents an audio clip or still image the name of the tab changes accordingly.
  • Use the Avoid pre-loading movie in media panel option in Preferences if you don't want to automatically open the movie file as soon as you edit a clip's details (for example, if opening the movie takes a long time).
  • If the movie or proxy tab has keyboard focus the tab label is shown with a darker background and you can use the keyboard to control movie playback, mark in and out points, and more. Click on the tab if necessary to give it focus.

Movie controller

When you play a movie (using either the clip details panel or the standalone media dialog) the following controls are available:

  • Use the space bar or click on the 'play' icon to play (or pause) a movie.
  • The current playhead (time position within the movie) is show by a red line. Click on the timeline to jump to another point in the movie.
  • The timecode of the current frame is shown in red. The duration of the clip or selection is also shown (in blue) but only if there's enough room. Click on the timecode field to jump to a particular timecode value.
  • Slide the in and out point markers to make a selection within the movie, or press the 'I' and 'O' keyboard shortcuts. Many other keyboard shortcuts are available also (hover the mouse over the controller buttons to display tool tip text to see which functions are available, or see the description of the media dialog).
  • You can play movies using codecs provided either by QuickTime or other media framework. A letter such as 'Q' shows which playback component is being used. Clicking on this button opens the Media Playback tab in Preferences where you can choose whether to use QuickTime or JMF and other options that affect how movies are opened.
  • When you play a QuickTime movie that has multiple audio tracks an audio icon appears. Click on this to choose which audio tracks to enable. Shift-click on a track to "solo" that track (disable all tracks apart from that one). If you make any changes from the default the icon changes to red to indicate a special setting is in effect.
  • If a clip contains timecode event markers these are indicated in the movie controller timeline. Use the keyboard Up and Down arrows to jump to the next event in the timeline.

Viewing and editing clip details

The Summary, Log Notes and Technical tabs display the various properties of the clip selected in the main window.

  • Some fields may be read-only while others can be edited by clicking on them.
  • If the value of the field is too big to fit comfortably on the display try double clicking on the field label to display the value in a separate window.
  • Select multiple clips and edit a value to apply the change to many clips at a time. The name field changes to say how many clips are selected. (Another way of applying a change to multiple clips in one go is with the Bulk Edit command.)
  • The Other tab provides an alphabetical listing of all available clip properties.
  • In the Professional Edition you can customise the layout of the details panel.

Logging menu

Use commands in the Logging menu to navigate within the clip details window, move to other clips, and perform logging.

  • Move up or down through the list of clips in the main window using Cmd/Ctrl-Up/Down.
  • After marking In and Out points create a New Subclip from the selection.
  • Split the current clip in two at the current play head position with Split Clip.
  • Review the transition between the previous clip and this one (ie. play the last few seconds of one and the first few seconds of this clip). This allows you to check whether they should be two separate clips or one.
  • If you want to combine them into one you can merge this clip into the previous one.
  • Use Toggle Subclip Limits to expand a subclip so you can view the entire source media file. The old subclip limits are stored as a selection in In2/Out2, so you can turn the clip back to a subclip again.
  • Use the Find Master/Subclip command to search for other clips in the catalog which refer to the same media, ie. to move between a master clip and its subclips.

Markers

In the Professional Edition you can create timecode markers to flag particular events of interest within a clip without having to create subclips for each event. Timecode event markers can also have a range and be assigned to particular categories, for example "highlights" or "bad language".

Defining marker categories

Under the Field Definitions section of Preferences, press the Marker Categories button to define your own event marker categories. Click '+' to define a new category or '-' to remove the selected category.

Marker categories have a name, a type, and can be assigned a colour which is used when displaying the marker in the Movie Controller. The following types are available:

Event marker
a single timecode value within the clip is flagged
Range marker
the marker has a start timecode and a duration and can be used to flag portions of a clip, eg. for "bad language".
Chapter marker
chapter markers are a special type of range marker and divide the clip into sections. When you insert a chapter marker the duration is automatically set to take it up to the next chapter mark.

Creating and using timecode markers

You create and edit event markers using the movie controller:

  • Use the 'flag' button (under the Movie or Proxy tab) to create an event marker for the current timecode value. (You can also use the 'm' keyboard shortcut if the player has keyboard focus.)
  • If you have defined marker categories in Preferences you can choose the category from the drop down list. You can also create basic single event markers without needing to define any categories.
  • For event and chapter markers the current playhead timecode is used. For range marker you need to make a selection in the clip using the 'i' and 'o' keys first.
  • Once you have created some markers a drop down underneath the movie controller lists all the markers for a clip. You can jump to that point in the movie by selecting it from the drop down.
  • You can edit an existing marker by holding down Shift when you press the 'm' key, or by double clicking a row in the Event Markers table. When editing a marker you can change the name or category, and you can also move the marker by dragging the playhead in the movie controller. (If you have already moved the playhead to where you want to move the marker to, hold down the Shift key while selecting a marker from the drop down: instead of moving the playhead it will update the marker instead.)
  • To delete a marker, click the Delete button in the edit marker dialog. You can delete multiple markers in one go by selecting them in the Event Markers table (under the Summary tab) and using the Clear Event Marker(s) command in the Logging menu.

Markers panel

Using the new Markers tab in the Details panel (enabled by checking the relevant tick box in Preference > Customise Details Panel) you can use the toolbar controls and click on the "hamburger" menu (with three horizontal bars) to:

  • customise which columns are shown for each marker
  • show custom marker columns (as defined using the CatDV Enterprise server web interface)
  • filter markers to only show markers of a particular category, or matching selected keywords
  • switch between fixed row heights or automatically flowing, multiline rows
  • highlight which markers searched for text appears in.

Other features

  • As well as the drop down in the movie controller, you can use the Event Markers table as a convenient way to see all the markers in one go, complete with their thumbnails and descriptions. (The Event Markers table is normally under the Summary tab unless you have customised the layout of the details panel.)
  • Click on the play button in the Event Markers table to play the movie from the start of the marker
  • You can convert to and fro between subclips and event markers using the Logging > Convert To Subclips or Edit > Merge commands respectively.
  • You can import and export event markers from QuickTime movie chapter markers, and from Final Cut Pro projects via FCP XML.
  • When you export a movie you can add burnt-in text from event markers as a simple way of creating subtitles.
  • Using Export As Stills you can export each event marker as a still image
  • You can also create event markers using the Verbatim Logger and using automatic scene detection.
  • You can copy and paste event markers from one clip to another (if they have the same timecode, for example multi-camera shoots with time of day timecode) by right-clicking on the header bar of the Event Markers table to display popup menu commands to copy and paste the markers. You can also use the Paste Metadata command.

Tree navigator

The tree navigator is shown on the left of the main window and provides a convenient way to organise the clips in a catalog, to browse files on the file system, and access other functions such as the contents of the CatDV server.

You can show or hide the tree navigator using the toolbar button or menu command.

Catalog node

The Catalog node represents all the clips in the current catalog.

  • If you are tempoarily viewing something else in the main window (for example, a catalog on the server), click on the catalog node to go back to the current catalog.
  • Click on All clips to reset any filters and view all the clips in the catalog.
  • Drag files or clips from another view onto the Catalog node to import them into the catalog.
  • The Sequences node provides a convenient way to access any sequences in your catalog.
  • Drag clips onto the Sequence node to create a new sequence.
  • If the catalog contains metaclips or image sequences these are shown in the tree. Clicking on the metaclip allows you to see the constituent files inside it.
  • If the catalog includes events these are show in the tree.

Smart folders

The Filters node provides some convenient ways of filtering the current view so you only see the clips you are interested in. If you create named filters these appear as Smart Folders. Clicking on a smart folder automatically applies that filter.

Automatic filters

Using Automatic Filters you can quickly organise the clips according to any clip property, for example grouping by date, by file format, by tape, or by bin. You can think of grouping as providing dynamic "virtual folders":

  • Drill down to find the clip property by which you want to arrange your clips. Expand this node (for example, Date or Bin or Media Path) to list individual grouping values, then click on the value to show the corresponding clips.
  • For editable properties you can drag clips onto another node to change the value.
  • You can combine the tree navigator with the grouping panel for two levels of grouping, for example by media path and then by format.
  • Select multiple grouping values in the tree (by holding down the Cmd or Ctrl/Shift modifier when you click on nodes) to combine the filters.

Server node

If you use the CatDV Server use the Server node to quickly browse clips on the server without opening up a remote catalog in a new window.

  • You can browse the entire database by catalog.
  • Catalogs can be organised into folders. Right click on the tree node to add a new folder.
  • Quickly perform a custom query by defining named queries under the Smart Folders.
  • Right click on a node and click Open For Editing to edit a catalog.

If you use the Enterprise Server additional features are available:

  • Use the tree navigator to load preference settings according to which project or production you are working on
  • Create and view shared group documents which are stored on the server (the "production blog").
  • Create Shared smart folders where the queries are stored on the server so they're available to everyone in the production group
  • Create named Clip Lists containing an explicit list of clips of interest. Drag clips onto the clip list node to add them to the list.
  • Use Browse All Clips to show thoe most recent clips on the server. Use the Quick Search box in the tool bar to narrow the search until you see the clips you want.

File system node

The file system mode provides access to your file system from within CatDV without having to switch to the Mac Finder or Windows Explorer.

You can browse directory contents using CatDV's media analysis features without having to import them into a catalog. You can also perform common media file management operations straight from the tree navigator, for example drag and drop to move or import files.

  • Drives and network volumes, as well as your home directory and desktop are shown.
  • Create additional shortcuts to your favourite locations by dragging a directory onto the main File System node.
  • Double click a node to analyse the media files in the folder and display the whole folder as thumbnails or a filmstrip.
  • Click on a file to play it in the clip details panel (unless you have the Avoid pre-loading movie Preference option set)
  • Directories which have already been analysed (and whose contents are therefore cached for quick access) are shown in bold.
  • Right click on a directory to show options such as delete or rename directory, to import it into the catalog using a specific importer, to search for a file by name, and more.

Under Mac OS X, click on a directory in the tree and type your search terms into the quick search box to perform a Spotlight search within that folder, for example to find all files of a particular type wherever they are on your hard disk. You can view thumbnails for the search results, sort them in various ways, and import selected results into your catalog.

Final Cut X libraries

The Final Cut node lists your recently used Final Cut Pro libraries and events. You can drag and drop clips and sequences from CatDV to Final Cut Pro X by dragging onto one of these nodes. This will save a temporary FCP XML file and tell Final Cut Pro to import the file.

Note that if you drag a clip straight to the Final Cut application window, whether from CatDV or the Finder, it is sent over as a file reference to the complete media file. Using XML and the Final Cut tree node is much more powerful however, as you can send subclips, log notes and sequences from CatDV to Final Cut and all the metadata is preserved.

Temporary views

When you use the tree navigator to view the contents of the file system, a catalog on the server, or the contents of a Final Cut project you are temporarily replacing the window's view on the current catalog with temporary clips. It is important to note that these temporary clips are not part of the current catalog and won't be saved when you save the catalog.

Because changes to a temporary view aren't saved in the catalog the clip details panel won't let you edit or add log notes to a temporary clip. Additionally, the background colour of the clips changes to a shade of red to remind you when you are in a temporary view.

It is easy to add temporary clips to the current catalog however. Simply drag and drop them onto the catalog node (or right click and select Import To Catalog). Once you do this they become normal clips that you can edit and save with the rest of the catalog.

Scratch Pad

The clip Scratch Pad is a holding area where you can drag clips of interest to save them temporarily, for example to build up a result set of clips from multiple catalogs or queries. Drag clips to the Scratch Pad node to save them, or drag them into a normal catalog window (or onto the Catalogs node) to add them to a normal catalog. Clips are stored in memory in the Scratch Pad as long as the CatDV application is open, even if you have closed the catalalog they came from.

If you prefer, you can use View > Scratch Pad to access the scratch pad via a new tab in the clip details panel rather than the tree navigator.

Customising views

Use the Customise Views command to create your own view definitions, containing just those columns (or clip properties) that you are interested in:

  • Select an existing view to edit, or define a new view. (Views that you have customised are shown in italics.)
  • When editing a view first select the basic type (film strip, list, grid, or icon only) then select the thumbnail size for the view and add the columns you want to show.
  • Add as many columns as you like (though some views only have room to show a limited number of columns - if you ask for too many those columns that don't fit are greyed out).
  • Rearrange their order by dragging and dropping columns in the right hand list or using the move up and down buttons.
  • If the same column name appears more than once (see making sense of property names), click on the name and use the description to distinguish them (eg. long and short versions of a file name).
  • Press 'Apply' to preview a view definition (without overwriting the previous saved definition).
  • Press 'Ok' to save the view definitions so they are available in other windows and when you next launch the application.
  • You may need to enable metadata columns via preferences if you don't see the values you want as separate fields.

Adjust column widths

Use the Adjust Column Widths command to automatically adjust the width of columns in a list view according to the data being displayed in them. You can also adjust column widths manually by dragging on the column divider line in the header row.

You can also rearrange the order of columns graphically by dragging the column header. However, you need to use the Customise Views command to add or remove columns.

If you make changes to the column widths then bring up the Customise Views dialog you are asked whether to import the current column widths into the view definition. You can then save the view definition including the column widths. Alternatively, use the Save Column Widths command. (If you do not save the column widths in this way then they will only apply as long as the current window is open.)

Customise details panel

In the Professional Edition you can customise which fields are shown in the clip details panel using the Customise Details Panel command. You can:

  • Create additional tab panels, either copies of existing ones or entirely new.
  • Choose which fields are included on each panel.
  • Choose whether long fields span both columns and whether fields are hidden if they are blank.
  • If you want a large, multi-line field to expand and fill the available space (eg. for the Notes or Event Markers field) add it as the last field on that tab.
  • Turn the predefined "HTML Summary" and "Other" tabs on or off.
  • Create your own HTML-basd tabs by defing a tab with the fields you want in it and checking the HTML option.

You can define different panels and choose which ones are visible at any time by checking or unchecking the visible flag. For example, different panels may make sense depending on which kind of asset you are working on.

Workspace configurations

Using workspaces you can quickly switch between different window layouts for different workflow tasks. The following workspaces are predefined:

  • Ingest - allows you to import files to analyse and catalog them
  • Log - designed for tagging clips with log notes, creating event markers, and using the Verbatim Logger
  • Browse - browse and search existing catalogs using automatic grouping and filtering
  • Create - select clips of interest and assemble them into a simple cuts-only sequence or shot list, then export them to various NLEs.
  • Advanced - provide access to the "classic" toolbar familiar from earlier versions of CatDV

Workspaces can be customised as required. When configuring a workspace you can control:

  • Which view definition is shown by default
  • Whether the tree navigator is shown by default, and which sections and nodes of the tree are shown
  • Which buttons, and other controls such as the quick filter field or drop down list of views, are shown in the toolbar
  • The appearance of the tree (using sections or split panes or a single flat tree) and toolbar (whether labels are shown, and whether the workspaces are shown as buttons or in a drop down)
  • Whether the clip details panel is shown (either with the media panel above the main window, or detached from the media panel and placed to the right of the window)
  • Which details panel tabs are shown
  • Which of the available workspaces are shown as shortcuts in the toolbar (note that they all appear in the View > Workspace menu)
  • It is also possible to override other regular preference settings such as which menu commands appear, whether deleting and editing of clips is allowed, and so on

You can edit the predefined workspaces or create new ones by using the View > Workspace > Edit command, but note that configuring workspaces is a specialised task that will normally be done by a systems integrator or workflow consultant when installing a system. Workspaces are defined using a simple text-based configuration script. In the workset editor press the 'Help' button to get a brief summary of the syntax, or press 'Defaults' to revert to the built-in predefined workspaces. If you don't want to use workspaces at all, simply delete all the workspace definitions and press OK. You can also choose the 'None' workspace if you don't want to override anything and just use normal settings from your preferences.

When you load a workspace all the settings specified in that workspace configuration are applied, to change the view and tree layout for example. Other settings which aren't specified by the workspace configuration continue to have their normal value as specified in the preferences dialog.

If you change one of these settings (for example, you decide you want to see the clip details panel even though the workspace you are using turns it off by default) then the value you have changed is remembered for the duration of the current session only. As soon as you quit and relaunch the application, or if you use the View > Workspace > Reload Rules command, then the workspace will revert to its default settings. This allows you to quickly change your view layout without messing up your stored workspace configurations.

To permanently change the configuration you need to explicitly use the workspace editor and then save your preferences. (It is also possible to configure a workspace with the LockSettings option, preventing any temporary changes from being made.)

User-defined fields

In the Professional edition you can have an unlimited number of user-defined logging fields. In Preferences you can give each user-defined field a name and specify its type:

Field types

The following types of field are available for user-defined columns and media metadata fields:

Don't Show
User-defined field values are stored by their index number so once allocated it isn't possible to delete a field and "shift the others up" as that would change the index numbers. Instead, you can mark unwanted fields so they are skipped and not shown. You can also mark metadata fields not be shown.
Plain Text
A free format plain text field. You can indicate whether this is intended for a single line or multiline text, though you can override this when adding the field to a custom panel layout.
Multiline Text
As above but normally shown in a scrolling multi line text area.
Grouping (Picklist)
A drop down pick list of values. The values are defined on the Pick Lists section of Preferences. Normally only a predefined value from the list can be chosen, unless the field is marked as extensible. Grouping fields can be used to quickly filter clips in the main window using the tree navigator or grouping panel.
Multi Grouping
Similar to Grouping fields, except that the clip can be tagged with any number of values from a list, for example a list of keywords. When tagging a clip, start typing in the field to display the first matching keyword, then use the Up and Down arrows to view other matches. Press ';' to start a new keyword, or click on the '*' button to display a chooser dialog.
Augo-suggest
Very similar to a grouping field with a drop down list of predefined values but you can start typing and the system will filter the choices based on what you type
Multi Auto-suggest
Like a multi grouping field with filtering capability.
Hierarchy
This is like a drop down pick list but where the available values are organised in a tree to make it easier to organise a large number of options (for example: continent/country/state/city) or when working with a structured vocabulary. Values are defined in the Pick Lists section, using '/' to separate the components.
Multi Hierarchy
A combination of functionality from the Hiearchy and Multi Grouping fields.
Linked Hierarchy
This allows you to link two pick lists, so the values shown in one depend on the value picked in another. You can the field id or name of the field it depends on in the parameter field. For example, if you had a grouping field called "Team" containing values TeamA, TeamB etc. then you could create a linked hierarchy field called "Player, "Team" in the parameters area, and with pick list values such as TeamA/Player1, TeamA/Player2, TeamB/Player3.
Linked Multi Hierarchy
A linked hierarchy field where you can select multiple values.
Checkbox
A single true/false checkbox. You can add an optional label for the checkbox in the parameters field, for example you might have a field called "Widescreen" with a label of "Anamorphic".
Multi Checkbox
Provides multi-grouping where the list of values is very small and can be displayed as checkboxes. The values are defined within the parameters area, one per line.
Radio Button
Similar to a Grouping field but where the number of options is small and can be specified within the parameters area (as for Multi Checkbox fields).
Select Buttons
Similar to radio buttons but where the options are defined in the pick lists section and appear as plain push buttons. In the parameters area you can specify the colour of the buttons.
Multi-Select Buttons
Similar to multi checkboxes but where the options are defined in the pick lists section and appear as plain push buttons. Just like single select buttons you can specify the colour of the buttons.
Date
Accepts a date or a date-time value. The format of the dates is specified in the General tab of Preferences (hover the mouse over the field to see tool tip help that shows an example of the format that it is expecting). You can also type in a date in ISO format, eg. "2016-12-31 23:59:59".
Time
Accepts either a time of day or a timestamp value, eg. "12:30:05" or "0:05:00;00".
Number
Accepts any numeric input, eg. "100" or "-17.5"
Identifier
Accepts an upper case alphanumeric identifier up to 32 characters, for example a project code number. Period, hyphen and underscore characters are permitted but other spaces and punctuation are removed.
No Punctuation
Accepts up to 80 alphanumeric characters plus space, hyphen and underscore. This is designed for entering short names or phrases that could be used when building a filename so punctuation and other illegal characters that can cause problems in filenames like period, asterisk, quotes, parentheses etc. are all excluded.
Regex Validated
For full control over what data can be entered in a formatted text field you can specify a regular expression in the parameters area. For example, "[A-Z][0-9]{3}" would only accept an upper case letter followed by 3 digits, eg. "A123" or "C999" and reject other values.
HTML Text
This is a special field that is not editable by the user but is used for displaying HTML formatted text that might have been stored in that field by a server plugin or worker script.
Calculated Field
If you create a user defined field of type 'Variable Expression' then this will result in a special kind of field where you can't directly type in a value but where the value is calculated dynamically based on other clip fields. The value is calculated when the clip is first loaded, or whenever the clip is modified. When configuring the field you can enter a CatDV Worker Node-style expression including regular expressions or use JavaScript. If the resulting value is of the form #rrggbb:xxx then it is interpreted as a hex color value. This provides another mechanism to achieve similar results to smart labels, and also to combine the results from a number of different fields into one. For example:
JSON-Formatted
For certain advanced workflows (e.g. using the Worker Node, server plugins, and Pegasus client) some fields might store read-only JSON-formatted data. You can display these using an HTML template such as
Object Link
If you use Pegasus Server you can have a special kind of field that links to a custom object. This feature is not currently supported in the desktop client.
Multi Object Links
As above but linking to multiple objects.

Please note that writing regular expressions and variable expressions, creating custom objects, and writing server plug ins to set HTML fields etc. are all very advanced topics designed for use by systems integrators or the Square Box Systems professional services team. A variable expression tester is available to help you test your calculated fields.

User and metadata fields

User-defined fields apply to clips and are commonly used to enter logging information, or to trigger Worker Node actions. They are commonly referred to by user field index, for example in worker scripts. If you use Server 7.1 there is a single "All Fields" field set that ensures user field indices are consistent across different production groups, but you can still control which user fields are visible in particular production groups by assigning them to a particular field group and setting visibility of that field group. Fields which are not visible in the current production group will be omitted or shown as "----". To set up field groups and field visibility (based on production group or user role) use the administration pages in the web interface. You can also remap the user field indices from within the web interface if necessary.

Media metadata fields apply to source media files and are normally created automatically when a file is imported to store technical metadata that is harvested from the file (for example, Exif metadata from still images, or XMP metadata from Adobe files). You can also create them manually if required, and can change the type and display label of existing metadata fields, just as you can with user-defined fields. You can also mark low level technical fields that you no interest in as "Don't show", so they hidden from display. An easy way to do this is to select the fields to hide and press the Delete key. You will be given the option whether to delete the field definition (but be aware that it might be added again automatically if it is encountered when importing a media file) or to mark is as being hidden.

Field definition sets

If you are using the CatDV Enterprise Server then you will be familiar with saving different preference settings to the server for each production group, so that all the users in that group automatically load the group settings when they log on and share the same field definitions, view and panel layouts, and other settings. If you want several different production groups (and the worker node) to share the same field definitions you can create a named field definition / config set and then choose which config set each production group should use. The field config set also stores other settings such as pick list values, marker categories, Final Cut 7 field mappings, and customised names for built-in fields.

If you use Server 7.1 (and leave the "Use Server 7 field definitions" option checked in Preferences) then field definitions are directly loaded from and saved to the server using the new server 7 metadata API. Field config sets are only used for other settings, and this is the recommended way of working. If you use Server 6 then fields definitions are loaded and saved via a named field definition set and you need to press the Edit button to explicitly edit this and ensure you have the latest version of the field set before making changes.

Pick lists

Fields of type grouping, multi-grouping, and hierarchy take values from restricted list of values. You can edit these via the Pick Lists button, or using the administration web interface.

Event details

Events provide a new mechanism for grouping related clips together. Often, there will be several clips that relate to the same occasion (for example, a particular interview or location, or an event such as a party). CatDV already provides a number of existing mechanisms for linking these clips, such as storing the media files in the same folder or assigning them a common bin name or user-defined grouping field value, but most of these mechanisms involve duplicating the description of the event in each field. With events the description is stored in the event itself. All the clips link to that event so the description is shared.

Assigning clips to events

You can create events and assign clips to them by selecting the clips to modify and using the Tools > Assign To Event command.

Several options are available. The simplest is to create a single new event, and assign all the selected clips to that event. You can also create and assign events automatically by looking at either the Bin name or Record Date fields of the clip (or both). Whenever the Bin changes, or the date of the clip differs by more than a specified interval from the previous clip (4 hours by default), a new event is created. You can also choose to assign clips to the closest existing event (if any) without creating new events.

Once events have been created they are stored in the catalog, whether or not any clips belong to that event. All the events in the catalog are listed in the tree navigator. As well as using the Assign To Events command you can drag clips on to an event in the tree to assign it to that event.

Editing events

Right click on an event in the tree to edit the event details. An event has a name, notes describing the event, and (in most cases) a date range which that event spans. You can also add custom metadata fields to the event by clicking the '+' button.

Using the tree you can merge two or more events into one. To do this, command- or shift-click the events in the tree to make a multiple selection, then right click and choose the Merge Selected Events command.

The Clean Unused Events will delete any events which don't currently have clips assigned to them. You can also manually Delete Events. (Deleting an event doesn't delete clips assigned to that event, it simply updates those clips so they are not tied to any event.)

CatDV "Field Logger" iPhone app

With the forthcoming CatDV Field Logger iPhone application (to be released shortly) you can already start logging events while on location in the field. Enter a description and keywords to describe the event, and automatically record the GPS coordinates of the event. Later, when you sync the app to your computer, an XML event log file is saved, which you can import using the Import Event Log command. This will automatically create events and link them to your clips (import the clips into CatDV separately, then link them based on the camera record date).

Using the CatDV logger app you can not only get a head start on logging events at the time the media is originally being shot but also geotag all your clips, just as if your camera had its own built-in GPS receiver.

Other features of events

  • Right click on the Events root node in the tree to choose whether events are grouped by year and month or not.
  • If you don't want to use events, uncheck the Show event commands option in Preferences.
  • If any clip within an event has geotag information associated with it then that metadata is shared among all the clips in that event. Click on the blue globe icon (either on the clip details "Summary" tab or in the Event Editor) to view the event location in Google Maps.
Despite the similarity in their names don't confuse events (a way of grouping related clips together) with timecode event markers (a way to mark specific frames of interest within a clip).